Guest Join UsHey Guest,
Welcome, Join our awesome community where you can discuss on various topics :-
Some point about your community
Some point about your community
Some point about your community
Some point about your community
Some point about your community
Some point about your community
Some point about your community
Much More.. or Create an Account


I am super Awesome Announcement, with links and can be used to announce important things. Check here
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
DuckDNS
#1
Switching from FreeNAS to an Ubuntu 16.04 Server setup, so this is my first experience with Docker.  I have another container running fine, but having issues with the one I thought would be easiest, DuckDNS.

The instructions at https://hub.docker.com/r/linuxserver/duckdns/ give a create command, which works fine and completes without issue. The quote from that page


Quote:Then run the docker create command above with your subdomain(s) and token
It will update your IP with the DuckDNS service every 5 minutes

seems to indicate that the create command is all that's needed, but seems to me a run command is needed or the container will just be inactive.  I attempt a


Code:
docker run duckdns


But get


Code:
[s6-init] making user provided files available at /var/run/s6/etc...exited 0.
[s6-init] ensuring user provided files have correct perms...exited 0.
[fix-attrs.d] applying ownership & permissions fixes...
[fix-attrs.d] done.
[cont-init.d] executing container initialization scripts...
[cont-init.d] 10-adduser: executing...
usermod: no changes

-------------------------------------
          _         ()
         | |  ___   _    __
         | | / __| | |  /  \
         | | \__ \ | | | () |
         |_| |___/ |_|  \__/


Brought to you by linuxserver.io
We gratefully accept donations at:
https://www.linuxserver.io/donations/
-------------------------------------
GID/UID
-------------------------------------

User uid:    911
User gid:    911
-------------------------------------

[cont-init.d] 10-adduser: exited 0.
[cont-init.d] 40_config.sh: executing...
Please pass both your subdomain(s) and token as environment variables in your docker run command. See docker info for more details.
[cont-init.d] 40_config.sh: exited 1.
[cont-finish.d] executing container finish scripts...
[cont-finish.d] done.
[s6-finish] syncing disks.
[s6-finish] sending all processes the TERM signal.
[s6-finish] sending all processes the KILL signal and exiting.

There are no examples of the run command needed for passing the subdomain/token to get this container going.  And I'm not sure why I'd need to pass this info in the run command anyway if they were specified in the create command.

Any ideas what I'm doing wrong?  Clearly my Docker ignorance is showing.  Thanks.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)

About LinuxServer.io

Focus MyBB Theme is designed for MyBB 1.8 series and is tested properly till the most current version of MyBB i.e. 1.8.9. It is simple, clean and light MyBB theme with use of font-awesome icons and shrinking header.

For any more information, please use our contact form.

              Quick Links

              User Links

              Advertise